Непреодолимая защита.

Ни один читер не сможет получить преимущества на вашем сервере с нашим продуктом.

SAP - Это лаунчер для minecraft, построенный на клиент-серверной технологии.

Обновление sap_launcher

Обновление системы скинов:
- Добавлено отложенное обновление клиента (смотрите документацию по скинам для подробностей)
- Добавлен макрос %launcher_version%, для показа версии sap_launcher
- Для элемента checkBox и client_select добавлен курсор мыши в виде руки.

Внимание: Обновлены системные библиотеки sap_launcher. Обновите свои инталляторы.

Обновление плагина plugin_auth_uni

Обновлен универсальный плагин авторизации.
- Добавлена поддержка CMS Invision Power Services;
- Исправлены мелкие ошибки;

Обновление sap_launcher

- Исправлены ошибки двойной распаковки архивов
- Добавлены макросы %system_memory_max% и %system_memory_free%
- Обновлен античит

Обновление

- Обновлен SDK до 2.0.4
+ Добавлен метод getPlayernameFromUuid
! Все плагины требуется пересобрать под новую версию (плагины auth_uni и auth_xenforo уже пересобраны и доступны для закачки)

- Изменена работа с uuid. Теперь это непременная часть

- Поправлен вывод статуса сервера, если он выключен. Теперь выдается последнее название сервера, которое было во время его включения

- Обновлена система скинов sap_launcher
+ добавлен новый объект LWTextBrowser, для отображение текста web страницы
+ Теперь при наведении мышкой на кнопку, курсор меняет свой вид

- Обновлен античит


Внимание: Если вы используете какой либо плагин авторизации, вы должны его обновить одновременно с sap_server.

Обновление sap_server

- Обновлен SDK
+ Все плагины требуется пересобрать под новую версию (плагины auth_uni и auth_xenforo уже пересобраны и доступны для закачки)
+ Метод generateUUID переименован в getUUID
+ Добавлен новый виртуальный метод existPlayername

- Реализованы API к серверу для получения uuid
+ Теперь команды сервера minecraft правильно работают с uuid

- Устранены некоторые ошибки авторизации


Внимание: Если вы используете какой либо плагин авторизации, вы должны его обновить одновременно с sap_server.